404 not found error

Resolved

AWS have confirmed this issue is now resolved.
Posted Jan 29, 2025 - 11:50 GMT

Investigating

Amazon Cloudfront are experiencing increased error rates. During this time, some of our users may experience “404 NoSuchBucket” errors. Amazon are actively investigating this issue.

Workaround - Refresh the webpage.
Posted Jan 29, 2025 - 10:38 GMT
This incident affected: Management Console (Waiting Areas Summary, Waiting Area Functionality, Organisational Units).