Reports of undelivered SMS Caller Arrival Alerts

Resolved

This issue is resolved.
Posted Jul 02, 2025 - 13:19 BST

Investigating

The team are investigating reports of undelivered SMS Caller Arrival alerts. All other areas of the platform are working fine.
Posted Jun 24, 2025 - 16:07 BST
This incident affected: SMS availability.